contact@exceltr.com

ExcelTR - Microsoft Excel Eğitim Sitesi

Görsel Video Microsoft Excel Eğitim Sitesi
23 Tem 2015

Fonksiyon Ile Sayfalar Arasi Baglantili Verileri Siralama

//
Yorumlar0
/

Bir onceki konumuzda ayni konunun makrolu versiyonunu konu edinmis ve anlatmistim.. simdi ayni konunun fonksiyonlarla nasil cozulebilecegine dair cesitli fonksiyon cozumleri sunacagim..

Yine ornek dosyayi indirmenizi ve anlattiklarimi ordan takip etmenizi isteyecegim, ilk olarak D3`teki formulumuzle baslayalim..

=IF(A3<>””,IF(ISNUMBER(MATCH(A3,$A$2:A2,0)),””,=COUNTIF($D$2:$D6,”>”&0)+1),””)
=EĞER(A3<>””;EĞER(SAYIDIR(KAÇINCI(A3;$A$2:A2;0)),””,EĞERSAY($D$2:$D6,”>”&0)+1;””)

Bu formulu parca parca incelersek daha iyi anlasilabilir saniyorum;

ilk parcamiz;

IF(ISNUMBER(MATCH(A3,$A$2:A2,0)),””,COUNT..

MATCH fonksiyonunun sonucu daima sayidir buradaki ornegimizde A3 degerini $A$2:A2 araliginda arar ve bu formul asagi sekildikce bu aralik buyur.. Burada A3 degerimiz “Mustafa” ve bu aralikta yok.. Formulumuzde bunu istiyor zaten ISNUMBER fonksiyonunun sonucu hayir cikiyor ve IF fonksiyonunun TRUE bolumu olan “” bolumunu gecip COUNT.. diye baslayan tarafa gecmesini sagliyor..

Simdi Bu COUNTIF`le baslayan bolumu inceleyelim;

=COUNTIF($D$2:$D6,”>”&0)+1

Bu fonksiyonumuz ıse $D$2:$D6 aralıgındakı 0″dan buyuk olan sayıların kac tane oldugunu sayar ve 1 ekleyerek bu sayıları bırer kez arttırır.. bu formulumuz ayrica F1 satirindada kullanilmis..

formulumuzu parca parca anlattik, fakat kafanizda mantiginin olustugunu saniyorum.. Bu formulle sonucuna vararak listedeki 6 degisik ismi suzmemiz kolaylasicak..

Buradan sonrasini lutfen dosyadan inceleyiniz, anlayamadiginiz formuller olucaktir, yorumlarinizda bunlari sorarsaniz konuya daha sonrada devam ederim, suan bellirli bi yogunlugu asmam gerekiyor, afiyetle..

Fonksiyon Ile Sayfalar Arasi Baglantili Verileri Siralama

Cevap bırakın


1 + 1 =