Excel Kesişim Değerini Getirme


[quote author=”- Baki”]Kolay gelsin,

Ekteki dosyada A sütununda ürün adları, A sırasında ebatlar, kesişimde ise fiyatlar vardır. (liste çok daha büyüktür, küçük bir kısmını aldım.) Giriş yaptığım ürün ve boyutuna göre fiyatın otomatik gelmesi için örnek K ve L de giriş yaptım. indis ve kaçıncı ile yaptığım fonksiyon ilk satırda – M1 – çalıştı ancak, aşağıya doğru kopyaladığım zaman kaydırdı. Çok uğraşmama rağmen çözemedim.

Konu ile ilgili değerli yardımlarınızı rica ediyorum.

Teşekkür ve Saygılarımla[/quote]

Konunuz bir nevi excelde Kesişim Değerini Getirme ile ilgili oldugu soylenebilir, ayni degerler tekrarlanmadigindan ben size sumproduct yani topla.çarpım fonksiyonunu onerecegim.

Fakat bunun icin daha oncedende hazirladigimiz farkli yollar vardi ve kesinlikle incelenmesi gerekir diye dusunuyorum.

Arama (Lookup) Teknikleri

Lookup-teknikleri

6 Farkli lookup Yontemi

Lookup Yontemleri

Sizin dosyaniz icin ise ornek cozum asagidaki gibidir direkt olarak uygulayabilirsiniz;

Ingilizce Versiyon;

=SUMPRODUCT(($A$2:$A$5=$K1)*($B$1:$I$1=$L1)*($B$2:$I$5))

Formda Turkce kullandiginizi velirttiginizden Turkce Versiyon;

=TOPLA.ÇARPIM(($A$2:$A$5=$K1)*($B$1:$I$1=$L1)*($B$2:$I$5))

Yazar: demo demo

2004 yilindan itibaren ozel bir sirketin finans departmaninda calismaktadir. Kendini excel, visual basic kullaniminda gelistirmis olan yazarimiz; Meslegi geregi SAP konusunda ileri derecede bilgilidir.

“Excel Kesişim Değerini Getirme” için 4 yorum

  1. Kolay gelsin, iyi haftalar,

    İvedi ilginiz ve çözüm öneriniz için teşekkür ederim.

    Farklı çözüm önerilerini, sizin değerli vaktinizi alacak sorumu sormadan önce pek tabiki inceledim. Sonuca ulaşamadığım için vaktinizi maalesef almak zorunda kaldım.

    Formulasyon için teşekkür ederim. Ancak sadece ve sadece 0 değeri almaktayım. (şu anda size iletimi yazdığım yerde “dosya ekleme” bulunmadığından tekrar dosyayı ekleyemiyorum.

    Düşeyara ve kaçıncı #YOK ; dolaylı dolaylı da #BAŞV! sonuçlarını üretmektedir.

    İvedi yardımınız için tekrar teşekkür ederim.

    Saygılarımla,
    Baki

    1. Merhaba oncelikle etsekkur ederim, sorunu dosyanizda gorsem daha iyi olacaktir.

      Aradığınız Konuyu Bize Yazın! adli formda dosyanizi tekrardan gonderiniz, youm bolumune dosya eklemeyi acmiyorum, cunku yorumlarla konular cok alakasiz oluyor, kullanici nereyi bulursa oradan soru gonderiyor ve biz soru cevaplamak adina degil konular acabilmek icin soru aliyoruz.

  2. Muhammet Mustafa Bey,

    Haklısınız, benim de gözümden kaçmış. Formulasyon mükemmel bir şekilde çalışıyor.
    Çok teşekkür ederim.
    Saygılarımla,
    Baki

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir


2 + 6 =